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Exercise 1: Visualizing multi-spectral images with Erdas Imagine 2011
a) View raster data:
Open file: File -> Open -> Raster Layer; select: E:/Data/DP5P2a/l7_20050710_30m.img
The provided data is a subset of an orthorectified Landsat 7 ETM+ scene contains all layers in a
single file. The scene is acquired 7 Oct. 2005 and represents the central part of western
Nyainqentanglha range in south-central Tibet. The stripes in the upper left are due to an scan line
failure of the instrument since May 2003.
View the metadata of an image: right click with the mouse on the file name in the table of
contents or Home -> Metadata
Question: What is the pixel size and the projection?
b) Visualizing an image in true and false colours
First improve the contrast of the image (Image enhancement):
Multispectral -> General contrast -> different options (try “Standard Deviation Stretch”)
Choose the different bands for displaying in the RBG mode:
Multispectral -> Bands -> Choose the different bands in the drop down menu
Try different band combinations (e.g. 3-2-1, 4-3-2 and 5-4-3)
You can see one specific band when selecting the same band for RGB.
Question: Which is best band combination for visualizing the glaciers and why?
c) Zoom in and out, pan etc.
Several possibilities to zoom etc. can be found In the toolbar of “Home” represented the typical
icons.
d) Check values of the pixels
The pixel values range from 0 until 255 (8-bit)
The value of each single pixel can be seen as follows:
Home -> Inquire ->Inquire -> A cross appears over the image and a window opens in which the
pixel value of the file and the display can be seen
You can move the cross to each pixel to see its value(s).

Exercise 2: Searching for suitable satellite data

We use the following region in south-central Tibet as an example:

Figure 1: Map of western Nyainqentanglha (source: Bolch et al. 2010, TC)

Open suitable search engine
Landsat and other data can be downloaded for free from USGS Global Visualization Viewer
http://glovis.usgs.gov
Select the best scenes
Suggested settings:
- Collection -> Landsat Archive -> L4-7 combined
- Resolution: 240m
- Maximum cloud cover: 30%
- Provide either the path/row of the Landsat scene or the centre coordinate of the region of
interest: Latitude: 30.3°, Longitude: 90.6°
- Select date of interest: Start with June 2000 (usually first suitable data for Landsat ETM+
data)
- Go backwards in time and then forward. What do you realize about the availability of the
scenes?
- Search the most suitable scene for the “detailed study region” (see. Fig. 1). Which scene
would you use for the glacier inventory and why?
- You may download (if already available) or order the scenes for download (processing time
usually 1-7 days) after registration (Not needed for this exercise).
In case the GLOVIS website is not running (java required…): Use www.landcover.org
click on ESDI (upper right below “Download Data”)
- Map Search
- Enter the coordinated from above (same for Min and Max)
- Preview and Download
- Select the most suitable scenes (click on ID) form Ortho, Geocover (best orthorectified
product). You can enlarge the scene when clicking on the thumbnail image
- What is the most suitable scene and why?

Exercise 3: Mapping of Glaciers using Multi-Spectral Images
a. Classification (Ratio Image)
The most easy and robust method to classify snow and ice is
- computing a ratio image between the NIR or RED band (TM4 or TM3) and the
SWIR band (TM5)
- and selection an appropriate threshold.
Another possibility would be the NDSI (Normalised Difference Snow Index, (VISSWIR)/VIS+SWIR)) with an appropriate threshold.
Realization in ERDAS:
Computing the ratio image
Typical indices like the NDVI are already included in this software package (Raster->
unsupervised -> indices). But the TM3/TM5 not.
Hence, we need to calculate the ratio image with the help of the model builder: I prepared
a simple model for the calculation (band_ratio.gmd).
Workflow: Toolbox -> Model Maker -> File -> Open -> Select “band_ratio.gmd”
A graphical view of the simple model is opening.
Double click on the symbol below “Input raster” and select “l7_20050710_30m.img”. The
default setting needs not to be altered. Click “OK”
Double click on the output raster and provide a file name “l7_20050710_ratio35_raw.img”
Select data type “float single” if not already set by default. Click “OK”.
Execute the model: process -> run (or click on the red flash)
Add now the result to the 2D view (file -> open raster layer)
Apply the threshold
First improve the contrast, if required (panchromatic -> general contrast)
Check with the “inquire cross” the best threshold of the ratio image, the value should be
around 2.0. Check especially the pixels around the glacier margins. You can blend between
the two images with “Home->Swipe or Blend”
We need to build a simple model for the calculation:
- First open the model builder
- Move two icons “raster layer” (second highest left) and the “circle icon” into the
empty space.
- Connect the icons with the arrow (from “Raster” to “Circle” to “Raster”): Click on
the arrow, move to the first object and draw the line from the first to the second
object.
- Double click on the first raster icon and choose the ratio image as input.

-

-

Double click on the second raster and define a suitable name for the output
(e.g.” l7_20050710_glacier_raw.img”). The output data type should be
“thematical”.
Double click on the circle -> a window opens; choose the “Relational” function
from the drop down menu (not really needed for this operation as one can also
type it in with the keyboard). Double click now on the correct input file which
should be greater or equal (>=) the selected threshold (e.g. 2.1). click “OK”
Run the model. The output file is now the raw glacier mask.

Analyse the raw result: What are the problematic areas?
Postprocessing
In the first postprocessing step we remove now some noise and isolated pixels
automatically. There a different opportunities, such as smoothing. Very suitable is
applying a statistical filter:
Raster-> Resolution -> Spatial Statistical Filter, multiplier e.g. 2.0 -> name output file (e.g.
“l7_20050107_glac_filt.img”) -> “OK”
Further postprocessing are the elimination of small misclassified pixels with an area
threshold and manual improvements of the glacier outlines
These steps are best to be performed in the vector domain. Therefor we need to convert
the raster to vector data while only those data should be vectorised which were classified
as a glacier.
Realization in ESRI ARCGIS
Remark: The Spatial Analyst must be enabled (Customize -> Extensions -> Spatial Analyst)
Open file: File -> Add data -> “l7_20050107_glac_filt.img” (or klick on the “+” icon in the
toolbar.
Classify only the glaciers pixels as “1” and the others should have a “no data”-value
(“Reclassify”, Usage in ArcGIS: Toolbox – Spatial Analysit Tools – Recalss – Reclassifiy)
“1” should remain “1” while “2” should be “no data” (type in the row “NoData”) -> output
raster “l7_20050107_glac_reclass.img” -> o.k.
Raster-Vektor Conversion
(Usage in ArcGIS: Toolbox – Conversion Tools – Raster to Polygon)
Input: “l7_20050107_glac_reclass.img” output: “glac_2005_raw.shp”
Delete misclassified pixels (e.g. small isolated snow patches, water)
Automated using a size threshold (common 0.02- 0.05 km²)
(Usage in ArcGIS: The editor toolbar is needed. In case it is not displayed: Customize –
Toolbars – Editor
Open the attribute table:
Right click on the vector file “glac_2005_raw.shp” -> Open Attribute Table

We need now a new column where the area information can be stored:
Click on the upper left icon of the table -> Add field -> Name: area, Type: Float, Precision
20, Scale 10 -> o.k.
Now right click on the row “area” -> Calculate Geometry -> Units: “kilometre” -> o.k.
The area was now calculated for all polygons.
Delete Polygons with an area <.0.5 km²:
Click on the upper left icon of the table -> Select by Attributes -> Type in the white field
“area” < 0.05 -> Apply
All the polygons smaller than 0.05 km² are now highlighted. In order to delete them the
editing must be enabled:
Editor Toolbar: Editor – Start Editing
You can now delete all selected polygons (either the delete button of the keyboard or
“Edit -> Delete”.
The edits should now be saved: Editor Toolbar: Editor -> Save Edits
Manual select and delete remaining obviously misclassified polygon
Obviously misclassified polygons (e.g. water bodies) should now be manually selected and
deleted. Save the edits afterwards.
If the scene was suitable and there are only clean ice glaciers you have no the final glacier
mask. However, usually further improvements are usually necessary due to debris on
glaciers, misclassified pixels in cast shadow, snow or clouds.
This is part of the next exercise.

Exercise 4: Mapping Debris-covered Glaciers
The main problem for the delineation of debris-covered glaciers is the correct identification of
the terminus of the glacier. The most accurate method is still the manual interpretation. There
is one characteristic debris-covered glacier in our test site (Question: Why is the glacier debriscovered?): Xibu Glacier (Fig. 2; for location see Fig. 1).

Figure 2: Terminus of Xibu Glacier 1974 and 2009.

This glacier shall now be manually delineated and its area change between 1974 and 2005
investigated.
I have therefore prepared to satellite images: one from 2005 which is a resolution merge of the
multispectral bands of a Landsat 7 ETM+ scene with its panchromatic band. The other one is a
panchromatic Hexagon KH-9-image from 1974.
The raw glacier file should now be manually improved for the year 2005 and 1974. We should
therefore first copy the automatically generate outlines.
Realization in ArcGIS:
Add files: File -> Add Data -> select: E:/Data/DP5P2b/l7_20050710_15m.img l7_2 and
kh9_1974.img
Copy the polygons:
Open ArcCatalog -> right click on shape file glac_2005_rew -> copy and past -> rename to
“glac_2005.shp”
Repeat copying and rename the file to “glac_1974”.
Add now both layers to ArcMap

Now the polygons should be manually adjusted.
Editor -> Start Editing
Select “adjust polygon” from drop down menu
You can now adjust the polygon: Start within the polygon – click around the debris-covered
glacier tongue and finish with a double click in the existing polygon.
Then save the edits.

Exercise 5: Splitting ice masses into single glaciers (Glacier Basins)
Simple approach
•
Create a buffer around the existing glacier polygons
(Usage in ArcGIS: Toolbox – Analysis Tools – Proximity – Buffer)
The buffer distance varies according to the glacier sizes. I found the best to be between 1 and 1.5 km
•
Clip the DEM to the buffer extent
(Usage in ArcGIS: Spatial Analyst Tools – Extraction – Extract by mask)
•

Remove all sinks from DEM

•
Calculate Glacier Basins
(Usage in ArcGIS: Spatial Analyst Tools – Hydrology – Flow Direction; – Basin)
•

Convert Raster to Vector

•
Delete all basins that do not contain glacier polygons
(Usage in ArcGIS: Selection – Select by location – Select glacier basins that intersect with or contain
glacier polygons – switch selection [in attribute table] – Delete selected polygons)
•

Improve basins manually if necessary (e.g. merge basins)

•

Optional: Extend attribute table of glacier basins (e.g. Glacier ID, Name, Watershed etc.)

•
Clip glaciers to basins
(Usage in ArcGIS: Toolbox – Analysis Tools – Extract – Clip)

Exercise 6: Glacier Area Changes / Monitoring
a. Search and Download suitable imagery from different time (here: use scene
l7_20010502_30.img, from 02.05.2001, you can use also the 1974 image)
b. Classification (see exercise 3)
c. Postprocessing (use existing outlines as additional information)
d. Split contiguous ice masses into single glaciers (see exercise 5)
e. Assign same id for glaciers as for those from the other period
f. The change of the debris-covered glaciers has to be manually adjusted (see exercise 4)
g. All glaciers on the 1974 image must also be manually adjusted.
h. Calculate the area (see exercise 3)
i. Change Analysis (visual and by value)
j. Sizes are displayed in the info table (highlight the respective file, then click on “table”)
Are the changes significant? What are the problems?

